.NET Tutorials, Forums, Interview Questions And Answers
Welcome :Guest
Sign In
Win Surprise Gifts!!!

Top 5 Contributors of the Month
Gaurav Pal
Post New Web Links

SqlCeSHA256 - PlatformNotSupportedException

Posted By:      Posted Date: May 22, 2011    Points: 0   Category :

I have a .NET 4 WPF application which uses SQL CE 4 (private deployment) as a database.

The application is deployed to many customers without problems, but one customer (running Windows XP) reports a PlatformNotSupportedException.

The stack trace is:

   bei System.Data.SqlServerCe.SqlCeSHA256.Initialize()
   bei System.Data.SqlServerCe.SqlCeSHA256..ctor()
   bei System.Data.SqlServerCe.HashProvider.CalculateHash(String filePath)
   bei System.Data.SqlServerCe.HashProvider.MatchHash(String filePath)
   bei System.Data.SqlServerCe.NativeMethods.IsValidBinary(String filename)
   bei System.Data.SqlServerCe.NativeMethods.ValidateNativeBinary(String modulePath)
   bei System.Data.SqlServerCe.NativeMethods.LoadValidLibrary(String modulePath)
   bei System.Data.SqlServerCe.NativeMethods.LoadNativeBinariesFromPrivateFolder(String privateInstall)
   bei System.Data.SqlServerCe.NativeMethods.LoadNativeBinaries()
   bei System.Data.SqlServerCe.SqlCeConnection..ctor()

I searched the web, seems like SHA256 was not supported in XP until SP3. But this customer must have XP SP3, because he's running .NET 4. Maybe this machine is missing some updates? If some component is missing on the machine, I want to find out w

View Complete Post

More Related Resource Links

System.Speech Throws PlatformNotSupportedException on Windows 7


Hi All,

Want to develop a little recognition program but unable to work with System.Speech namespace, i'm using Windows 7 with Turkish language, is that a problem? Am i ahve to install English version?


Th Error I Get:



PlatformNotSupportedException was unhandled.

No recognizer is installed.



PlatformNotSupportedException: Microsoft SharePoint is not supported with version 4.0.30319.1 of the


PlatformNotSupportedException: Microsoft SharePoint is not supported with version 4.0.30319.1 of the Microsoft .Net Runtime.

You read a lot on the internet about this: http://vspug.com/sharedpoints/2010/10/

Not being able to use .NET 4.0 assemblies is understandable when your have a webpart and sharepoint refers to your project.

But when you are referring to SharePoint it should not matter, it works perfectly in 2007, so why not 2010???

I need .NET 4 (discovery and such) in this project, so I need another solution than just downgrading the target framework

System.PlatformNotSupportedException exception


I am getting System.PlatformNotSupportedException exception on running this code. can anyone tell me what is the problem in this code.

 public IList<ProductLine> GetProductLines()


            //TODO Get Product Lines from SharePoint

            List<ProductLine> productlines = new List<ProductLine>();



ASP.NetWindows Application  .NET Framework  C#  VB.Net  ADO.Net  
Sql Server  SharePoint  Silverlight  Others  All   

Hall of Fame    Twitter   Terms of Service    Privacy Policy    Contact Us    Archives   Tell A Friend