.NET Tutorials, Forums, Interview Questions And Answers
Welcome :Guest
Sign In
Win Surprise Gifts!!!

Top 5 Contributors of the Month
Gaurav Pal
Post New Web Links

.net3.5sp1 hotfix.

Posted By:      Posted Date: September 16, 2010    Points: 0   Category :.NET Framework
Hi everyone, I've a custom library written in .NET 40 that implements a WCF client to connect to a JAVA Web Service. For interoperability reasons I have to set to true the EnableUnsecuredResponse of a custom asymmetric binding element. Now, because my customer have Visual Studio 2008 and a lot of servers with .NET Framework 3.5SP1 installed, I try to 'downgrade' the project to that framework. The property above isn't present in that framework but, I read on some other posts, there is a fix from Microsoft that enable that feature on 3.5SP1. The fix (http://support.microsoft.com/kb/971493) is there but I can't download it from everywere. After some searches, I find a downloadable hotfix rollup at Code Gallery but is only for Windows 7 and WindowsServer 2008 r2: http://code.msdn.microsoft.com/KB981002 Something similar for Windows XP/ Windows Server 2003 ? Maybe someone can help me? Thanks in advance, Gianni Ghezzi.

View Complete Post

More Related Resource Links

TypeLoadException for DropShadowEffect on .net4.0 when .net3.5sp1 not installed

Hi, I've been starting to get a TypeLoadExceptions on some clients: Could not load type 'System.Windows.Media.Effects.DropShadowEffect' from assembly 'PresentationCore, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35'. The problem is repeatable on systems where .NET4.0 is installed but .NET3.5sp1 isn't. Looking at the GAC on a system with only 3.0 and 4.0 installed, PresentationCore exists and is at version Am I missing something or is the DropShadowEffect missing from the 4.0 installation? Please help me solve this! Sincerely Andreas

Missing/Required binary files on one Web-front-end after installed the CU aug 2010 hotfix?

Hi! I have installed the binary files for CU aug 2010 hotfix in a farm with two web-front-ends. In Central Administration you can see that on Web-front-end one (that also is hosting the Central Administration app) the binary files are missing but not on the second Web-Front-End. The installation went fine on both servers with the exception that I had to reboot the Web-Front-end one. When I try to run Psconfig to update my databases I get en error message like this in my command prompt. The upgrade command is invalid or a failure has been encountered. The server farm will not work with missing installs. Add "-cmd installcheck -noi nstallcheck" to the command-line to ignore this warning. The following is missing on web-front-end one: Hotfix for Office (KB2352342) Hotfix for Office (KB2352342) Hotfix for Office (KB2352342) Hotfix for Office (KB2352342) Hotfix for Office (KB2352342) Hotfix for Office (KB2352342) Hotfix for Office (KB2352342) Hotfix for Office (KB2352342) In the event log I get a lot of these errormessages too (EventID 3351): SQL database login for 'SharePoint_Config' on instance 'SqlAliasName' failed. Additional error information from SQL Server is included below. Login failed for user 'Domian\servername (one)$'. The thing is that the files is installed in the filesystems aswell as the dll files in the GAC on both servers. You can´t unistal

hotfix 3024 error code 1603 - failed install

Hello experts - Installing sql server 2005 on a 2 node cluster and failed with the above error.  I see lots of posts regarding this error, but no answers.  A search of the registry reveals no 3024 entries. Any help appreciated - DianneDianne

Error selecting "Business Data Connectivity" service application in MSS 2010 with WCF hotfix on W8R

I'm getting "BDC Metadata Store is Currently Unavailable" when navigating to the External Content Types object in SPD 2010. Hot fix is installed.  No errors in the eventlog? 

Using methods of a .net 4.0 dll by .net 3.5sp1 client.

Hi everyone, I've writed a dll using .net 4.0 to wrap a java service to the .net world, and I can't retarget it to a lower framework version. Now I need to use that dll into an existing project writed (and not upgradable to .net 4.0) in .net 3.5sp1. If I add a reference in a test app written in 3.5sp1, VS2008 arises an error (can't reference the dll). Can I do it ? Thanks in avance, Gianni Ghezzi.

Hotfix 946517 for Windows Server 2008 R2

Does anyone know if Microsoft has released this patch for Windows Server 2008 R2/Windows 7. I only show Windows Server 2008.For more information check out my blog; http://blogs.pointbridge.com/Blogs/pagnusat_tony

SQL Server 2008 R2 Service Pack or Hotfix for ReportExecutionService2005 broken with IMAGE/EMF

Posted by edwardforgacs on 8/23/2010 at 4:13 AM
Vlad_MSFT, any update on the ExecutionInfo.NumPages workaround? It's well over a month since you posted to this thread and by the looks of it I'm not the only person who is unable to get any useful information out of that.

As Bob_eBlueprint mentioned, it always seems to return zero. Do you actually have a tested code sample where it works?
Posted by edwardforgacs on 7/20/2010 at 2:11 AM
Yes, ExecutionInfo does not return the number of pages properly either. I have tried every possible combination including GetExecutionInfo, GetExecutionInfo2, before and after render, and combined with Render, and Render2. Guess we need to open another bug about GetExecutionInfo not working in 2008 either?
Posted by Bob_eBlueprint on 7/9/2010 at 10:32 AM
I tried using the code posted by JasonRAC, but I am not getting an exception thrown when I try to render a page that doesn't exist. Instead a zero byte array is returned. So I'm using code like this to stop rendering when the end of the report is researched:

        Dim DidPageLoad As Boolean
        Dim TempPage As Byte()

Hotfix request links to Cumulative Updates 9 and 10 for SP1 do not work


Last week I was able to obtain CU9 for SQL Server 2008 SP1.  This week, I cannot even make a request for CU10 or CU9.  Since Saturday, I have received the following reply whenver I click on a hotfix link:  Hotfix Request
The system is currently unavailable. Please try back later, or contact support if you want immediate assistance.http://support.microsoft.com/contactus/?ws=support

If I attempt to contact support in any way, they want to charge me.  What is going on?

will installation of .NET 3.5sp1 or 4. affect an existing SQL2005 std server?

current sql2005 SE on w2k3 enterprise, has .net 2.0 on it, since there are databases for different applications, one application requrest upgrade .net framework to 3.5sp1, not sure if this will affect any other databases, I think this should Not affect it since the applications are running on seperate servers from sql server, anyone please answer or confirm, thanks

Web Developer 2010 Exress: How to save to .NET3?


Hi. Is there a way to export the website that I have created to .NET3 usubg Web Developer 2010 Express? I assume by default it is save as .NET4.

I just want to be able to copy the website that I have created directly to IIS 6 server. Thanks in advance. 

WSS 3.0 Hotfix


Hi guys,

Where can i find the latest service pack/hot fixes for WSS 3.0?

 2. How do i check my current patch level?


SQL 2005 32 SP3 hotfix on 64 bit OS issue


There is a problem in upgrading 4035 to 4053. and getting error as like SQL Server Database Services 2005 (MSSQLSERVER)  Setup cannot update SQL Server Database Services 2005 x86 on this computer. To proceed, run the Hotfix Setup program for the x86 platform instead.'. This is 32 bit sql server on 64 bit OS. Any idea why is not upgrading ?


.net 3.5sp1 and .net 4 installation


Hi all,

      I have tried to install the pex and moles tool with visual studio 2010 ultimate but it is not being installed though the installation completes. I uninstalled all the extensions I had and tried to install again but the result is the same. While installing the pex tool I saw that the installation searches or does something with the 3.5 runtime assemblies, so I thought I will try to install .net 3.5sp1. I have .net 4 installed on a fresh windows 7 professional. When I try to install the .net 3.5 sp1 it it is not being run.. it extracts the contents then nothing... I saw a dialog once asking whether the program was installed properly or not...

      Is it ok to uninstall the .net 4 and install 3.5sp1 and then install .net 4 on top of it ? will it mess up my Visual studio install ??


Unable to request Cumulative Update or any hotfix


I need to install the Feb 2010 CU for SharePoint 2007 (x86). This is KB978395. When following the link to request the hotfix, I am presented with the error message "The system is currently unavailable. Please try back later, or contact support..." I have tried accessing for several days. Have checked firewall settings, turned off anti-virus. Tried using Windows 7, Windows Server 2003, IE8, Firefox, Chrome - all with the same result. Although this particular update is what I need (to get a development VM to the same build number as a client's production system for troubleshooting a problem), ANY hotfix request returns the same error. I am in New Zealand, but have used this service fine in the past. The specific URL in question is http://support.microsoft.com/kb/978395 (but any hotfix request has the same problem). A search on the error message shows other people routinely have the same problem.

Any help would be appreciated.



I am facing the following error:

"Hotfix installer has stopped working" when i try to install the MS SQL Server 2005 update using Windows Update.

My OS is MS Vista Ultimate version


Please help.


Thank you


The Business Data Connectivity metadata store is unavailable. (WCF hotfix is installed)

Trying to create an External Content Type in SPD and received this message.  I did some research and installed WCF hotfix and still got this message.  After some more troubleshooting, determined that it is related to SSL because when I open the non-SSL site (same site just http instead of https), I CAN create the External Content Type.  Has anyone seen this and have a solution?  Thanks in addvance for you help.

Popup with ScrollViewer and VerticalScrollBarVisibility=Auto not displaying correctly in 3.5sp1


If I have a Popup which contains a ScrollViewer and I set VerticalScrollBarVisibility=Auto, if the scroll bar is required the Popup is not sized correctly. This looks like it was fixed in 4.0  ( at least my test case works in 2010 and not 2008 ) but I'm hoping there's a workaround for 2008 since I can't move to 2010 yet. Here's some example XAML which shows the issue

ASP.NetWindows Application  .NET Framework  C#  VB.Net  ADO.Net  
Sql Server  SharePoint  Silverlight  Others  All   

Hall of Fame    Twitter   Terms of Service    Privacy Policy    Contact Us    Archives   Tell A Friend