.NET Tutorials, Forums, Interview Questions And Answers
Welcome :Guest
Sign In
Win Surprise Gifts!!!

Top 5 Contributors of the Month
Gaurav Pal

Home >> Articles >> ASP.NET >> Post New Resource Bookmark and Share   

 Subscribe to Articles

Setup and Deployment In Windows Using Visual Studio PART-2

Posted By:BangaruBabuPureti       Posted Date: June 30, 2010    Points: 25    Category: ASP.NET    URL: http://www.dotnetspark.com  

In Second part, I totally focused on Set Up and Deployment Procedure by using PART-1 developed Code and Their dependencies.

Windows Set Up And Deployment - PART-2

Setup and Deployment using The Previous PART-1 development Code of The Article

Continuation To Part-1.......


Open Visual Studio->New Project->In Project Types Select Other Project Types->In Templates Select Setup Project-> Assign Name as Your Choice ->I Assigned SETUPMERLIN-> In Set Up Project we have File System Section-> In That we have Three Sub Folders Name as

 1) Application Folder 2) User's Desktop 3)User's Programs Menu

Step by Step I described The Purpose of Each And Every Folder

1)    Application Folder:

a)This is the heart of  Setup and Deployment Folder, where we need to place exe files, dependent dlls,dependent images,icons,Databse Files, dependent File Folders[Like doc,ppt,pdf] e.t.c

b)Keep like Blind Identification-Place Files What ever the Targeted System Needed.

c)What ever the files Placed In Folder fall under Installed Location weather it may be a Program Files or it may be a Customized Installation Folder

             2)    User's Desktop:

 Place Files What Ever You need on The Desktop after installing the setup file in the targeted Machine

3) User's Programs Menu: 

Place Files What Ever You need on The User Programs[Windows-Start-All Programs] Menu after installing the setup file in the targeted Machine


Right Click on Application Folder->Select Add->Select File


It opens Add File Dialog Box-Go to the Project Folder What we did in The Previous PART-1(I Named My Project as MerlinSetUpProject)-Below The File Location In My PC where the code Available


Go to Bin\Debug Folder add all files [.exe's, .dll's, .mdb, .acs] what client system needed, here select files like MerlinSetUpProject.exe, AxInterop.AgentObjects.dll, Interop.AgentObjects.dll, Interop.AgentServerObjects.dll, merlin.acs, myDataBase.mdb.and Click On Open


Add Images what you needed, here I need icon for .exe file For User Desktop Shortcut as well as Programs Menu Short Cut.

Right Click on Application Folder->Select Add->Select File-Add MyIcon.ico [Add What ever U want as Short Cut Image] from Desktop-Then it will add to Application Folder


 Now My application Folder Looks with the Following Content


 Now Right Click On The MerlinSetUpProject.exe and Click on Create Shortcut to MerlinSetupProject.exe..Create Two Short Cuts for this exe


After creating shortcuts Application Folder contains the following two files as Marked Below


Now drag and drop one short Cut File in User Desktop Folder and One in User's Programs Menu Folder.->Open User Desktop Folder and User's Programs Menu and Rename Short Cut exe file Name as your choice -which were depicted in following Screen Shots

Do The same For User's Programs Menu Folder


Assign Icons For Short Cuts

a) Click on User's Desktop Folder -Right Click on Shortcut -Click Properties Window->In Properties Window Select Icon Property ->Select Browse

b) Click Browse

c) After Clicking Browse->Icon Dialog will Opens->Click On Browse->

d)  Item In Project Dialog Will Open

e)Click On Application Folder-

f)Select MYICON.ICO and Press Ok-Again Click OK


Repeat the same step-10 for the User's Programs Menu Folder


Now Build the Project

Then Set Up is Ready To Use.

Note: Open -Set up Project in Your Hard Disk-It Consist of Bin\Debug Folder which is depicted in The Following Screen. Which consists of Windows Installer Package.

You can deliver this .msi to the clients and Install

Before going to install this Microsoft Installer Package @ Client we need the following Pre-Requisites to Be Installed

Microsoft Windows Installer 3.1

.Net Framework 2.0 /3.5

Finally Our .msi package.

Installation Procedure In Client Desktop


Double click on SETUPMERLIN.msi  package ->It will opens the screen as follows



Click On Next


Select Every One For Using All Users In Windows->Click Next->Next ->Close


Installation Completed Successfully-See my Desktop and Programs Menu is Having Shortcut Icons of Merlin Project 


Program Menu

Summary and Conclusion

  1. In This Article I Explained and Covered 100% Round Trip In Windows Deployment By Using Microsoft Access Database. It is even same for Sql Server.
  2. For Sql Server it is a mater of Constructing Connection String Dynamically That's it
  3. I explained Merlin COM Component In Brief
  4. I hope This Article Helps for Beginners to Advanced Learners

 Subscribe to Articles


Further Readings:


No response found. Be the first to respond this post

Post Comment

You must Sign In To post reply
Find More Articles on C#, ASP.Net, Vb.Net, SQL Server and more Here

Hall of Fame    Twitter   Terms of Service    Privacy Policy    Contact Us    Archives   Tell A Friend