.NET Tutorials, Forums, Interview Questions And Answers
Welcome :Guest
Sign In
Win Surprise Gifts!!!

Top 5 Contributors of the Month
david stephan
Gaurav Pal

Home >> Forum >> ASP.Net >> Post New QuestionBookmark and Share Subscribe to Forum

Create new Database connection error

Posted By: Nehal     Posted Date: September 16, 2009    Points:2   Category :ASP.Net
I am using Visual studio 2005 express eddition. I haven't install SQL server. I m using only express Sql server which is comes bydefault with visual studia. Now problem is that when i create first time new database then it create successfully. but when I m try to create another database then it is not allowed me to create another database. If there any solution?? I have also tried delete my first database. and then make another database. but it not support. Please say me the solution of this.

The error is as follow:

An error has occured while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server doesnot allow remote connections.
(provider: SQL Network Interfaces, error: 26- Error Locating Server/Instance Specified)

Author: Akhil Raj       [Moderator]      
Posted Date: September 16, 2009     Points: 5   

hi friend,
check the instance of the server and check tcpip protocols are enabled or not.. Are you using SQL Server Mangament Studio Express ?

Anyway please read and check the following blog about this issue..


Author: Venkat             
Posted Date: September 16, 2009     Points: 5   

Hi Nehal,

to enable remote connection by SQL server to accept connection by remote system you can do the following steps

Enable remote connections for SQL Server 2005 Express or SQL Server 2005 Developer Edition
You must enable remote connections for each instance of SQL Server 2005 that you want to connect to from a remote computer. To do this, follow these steps:

1. Click Start, point to Programs, point to Microsoft SQL Server 2005, point to Configuration Tools, and then click SQL Server Surface Area Configuration.
2. On the SQL Server 2005 Surface Area Configuration page, click Surface Area Configuration for Services and Connections.
3. On the Surface Area Configuration for Services and Connections page, expand Database Engine, click Remote Connections, click Local and remote connections, click the appropriate protocol to enable for your environment, and then click Apply.

Note Click OK when you receive the following message:
Changes to Connection Settings will not take effect until you restart the Database Engine service.
4. On the Surface Area Configuration for Services and Connections page, expand Database Engine, click Service, click Stop, wait until the MSSQLSERVER service stops, and then click Start to restart the MSSQLSERVER service.

More details can be found here for this problem

Mark As Answer if this solve your problem
Warm Regards,
Author: Nehal             
Posted Date: September 17, 2009     Points: 5   

yaa thanks sir..

Post Reply

You must Sign In To post reply
Find more Forum Questions on C#, ASP.Net, Vb.Net, SQL Server and more Here
Quick Links For Forum Categories:
ASP.NetWindows Application  .NET Framework  C#  VB.Net  ADO.Net  
Sql Server  SharePoint  OOPs  SilverlightIISJQuery

Hall of Fame    Twitter   Terms of Service    Privacy Policy    Contact Us    Archives   Tell A Friend