.NET Tutorials, Forums, Interview Questions And Answers
Welcome :Guest
Sign In
Win Surprise Gifts!!!

Top 5 Contributors of the Month
Gaurav Pal

Home >> Forum >> .NET Framework >> Post New QuestionBookmark and Share Subscribe to Forum

Do I need lot of different version of dot net installed

Posted By: Keyser soze     Posted Date: August 24, 2012    Points:5   Category :.NET Framework
Hi I have a customer who we have been supporting for a while and throughout there life with us they have installed on there PC's .net 1.1, .2.0, 3.0, 3.5 and now we just install .net 4.0.

My question is do they need all these version installed or will 4.0 allow any software requiring any of the previous to work without issue?

For example: I do know the customer runs to different software packages and one has a prerequisite of 3.5 and the other states it requires 4.0

Author: BitWise             
Posted Date: August 24, 2012     Points: 20   

4.0 will provide all the functionalities....you dont have to installed all other...

Author: Keyser soze             
Posted Date: August 24, 2012     Points: 20   

Thanks for you reply Bitwise.

Yeah from what I gleam from the readme.txt it kind of implies that. However I don't like the statement .net 4.0 will work side by side with previous versions. Why would it need to and what conditions would warrant this need?

Granted im no .net programmer but could it be a programmer who created an app years ago where he was stupid enough to hard code the existence of .net 2.0 and if that's the case would .net 4.0 or windows be clever enough to redirect the old app to .net 4.0

I suppose it's simply a case of sucking and see :)

Author: BitWise             
Posted Date: August 24, 2012     Points: 20   

.net 4.0 will work side by side with previous versions, it will be helpful for companies who provides services in both .Net previous versions and started giving it for newer versions....

Author: kamlesh             
Posted Date: August 27, 2012     Points: 20   


If you develop application in Dot net Framewsork 3.5 and you install framework 4.0 on client machine
then then it gives you
Error "unable to find a version of the runtime to run this application .net framework"

for that create App.config file in that application

contains of App.config file
<?xml version="1.0" encoding="utf-8" ?>
<startup useLegacyV2RuntimeActivationPolicy="true">
<supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>
<supportedRuntime version="v2.0.50727" />
<supportedRuntime version="v1.0.3705" />
<supportedRuntime version="v1.1.4322" />

when you rebuild your application you get application.exe.config
file take that file also with your exe (application.exe)

so it will work on 4.0 framework.

Thanks And Regards.
Kamlesh Nikam
Author: Ravi Ranjan Kumar             
Posted Date: August 31, 2012     Points: 20   

Never. Higher level of version can include each and every needed functionality of lower level of version. so feel free to Install higher level of version.

Thanks & Regards
Ravi Ranjan Kumar
Author: Johnny             
Posted Date: December 17, 2012     Points: 20   

No need to install a different .net version install 4.0 as of now


Post Reply

You must Sign In To post reply
Find more Forum Questions on C#, ASP.Net, Vb.Net, SQL Server and more Here
Quick Links For Forum Categories:
ASP.NetWindows Application  .NET Framework  C#  VB.Net  ADO.Net  
Sql Server  SharePoint  OOPs  SilverlightIISJQuery

Hall of Fame    Twitter   Terms of Service    Privacy Policy    Contact Us    Archives   Tell A Friend