.NET Tutorials, Forums, Interview Questions And Answers
Welcome :Guest
Sign In
Win Surprise Gifts!!!

Top 5 Contributors of the Month

Home >> Forum >> IIS >> Post New QuestionBookmark and Share Subscribe to Forum

how to solve dis error" virtual directory not being configured as an application in IIS"

Posted By: parthiban     Posted Date: June 08, 2012    Points:5   Category :IIS
. This error can be caused by a virtual directory not being configured as an application in IIS

Author: Syed Shakeer Hussain             
Posted Date: July 07, 2012     Points: 20   

Change authentication mode to 'None ' in web.config.

Go to your web.config file and change following line

< authentication mode="None" />

This should solve this problem.

Note: If above solution does not work then make sure that the directory from where you website is running is configured as an application in IIS. To do this, you need to go into IIS and find your project folder on the server, right click to Properties. Under Application Settings click Create.


By default ASP.Net creates Windows authentication mode in Web.Config file. When you run this site locally on your computer, it runs fine. This is because it runs under current windows account credentials (i.e. Your windows login which may have administrative rights). But when you copy it to web server it runs under [MACHINENAME]\ASPNet account. If it does not have appropriate rights, server will throw this error[/BLUE]

Author: Vishal Jadhav             
Posted Date: December 21, 2012     Points: 20   

You have to set admin authentication to the virtual directory. Check the property of ur IIS folder. There is a option set as...set admin authority to the website

Post Reply

You must Sign In To post reply
Find more Forum Questions on C#, ASP.Net, Vb.Net, SQL Server and more Here
Quick Links For Forum Categories:
ASP.NetWindows Application  .NET Framework  C#  VB.Net  ADO.Net  
Sql Server  SharePoint  OOPs  SilverlightIISJQuery

Hall of Fame    Twitter   Terms of Service    Privacy Policy    Contact Us    Archives   Tell A Friend