.NET Tutorials, Forums, Interview Questions And Answers
Welcome :Guest
 
Sign In
Register
 
Win Surprise Gifts!!!
Congratulations!!!


Top 5 Contributors of the Month
david stephan

Home >> Forum >> .NET Framework >> Post New QuestionBookmark and Share Subscribe to Forum

Error 0x800B010B when installing .NET 4 Framework on Windows 2003 Server, SP2

Posted By: signal     Posted Date: September 16, 2011    Points:5   Category :.NET Framework
I had trouble installing windows updates. I would constantly get an error from windows update that indicated there was a a problem with the security credentials:

The error I got was 0x8007f0da

I followed all of the tasks identified to fix this at:

http://support.microsoft.com/kb/958050

they did not resolve the issue. So I went on to the "Advanced Troubleshooting" specified in the article at this location:

http://support.microsoft.com/kb/822798

I tried everyone of these steps, with no avail. One of the updates that it could not install was .NET 4, so I was also investigating that issue. In the process I ran .Net Cleanup Tool:

http://blogs.msdn.com/b/astebner/archive/2006/05/30/611355.aspx

After doing this I tried to re-install .NET 1.1, 1.1sp1, 3.5 and 2.0, but was only able to reinstall 3.5, as 1.1 and 2.0 were part of the Windows 2003 operating system. After installing .NET 3.5 Windows Update installed numerous 3.5 updates/fixes.

I ran .NET Framework Setup Verification Tool and it showed all of my .NET's installed were fine, except 1.1.

http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

So then I proceeded to manually fix my 1.1 install by following these instructions:

http://blogs.msdn.com/b/astebner/archive/2005/06/21/431385.aspx

After following these instructions, and re-running the .NET Framework Setup Verification Tool, it shows all my .NET's in good:

.NET Framework 1.1 SP1
.NET Framework 2.0 SP2
.NET Framework 3.0 SP2
.NET Framework 3.5 SP1

I then manually download dotNetFx40_Full_x86_x64.exe and try to install it and it fails. The error I get is:

[9/16/2011, 14:27:8]Failed to verify and authenticate the file -C:\c7290308adb3cdc4f3c4424c046838cc\netfx_Core_x86.msi
[9/16/2011, 14:27:8]Please delete the file, C:\c7290308adb3cdc4f3c4424c046838cc\netfx_Core_x86.msi and run the package again

I follow the instructions here to extract the file and verify the certificate:

[9/16/2011, 14:27:9]Final Result: Installation failed with error code: (0x800B010B), "Generic trust failure. " (Elapsed time: 0 00:00:05).

So I went to the original dotNetFx40_Full_x86_x64.exe file, Right Click, Properties, Digital Signature, saw it was valid, did View Certificate, and Installed the Certificate for good measure. Still same error.

I removed the file C:\c7290308adb3cdc4f3c4424c046838cc\netfx_Core_x86.msi as it told me to. I did not see where I could "disable .NET" and then re-enable it like you can in some other versions of Windows: (Start button -> Control Panel -> Programs -> Turn Windows Features on or off -> clear check box next to Microsoft .NET Framework). I cleaned %temp%, rebooted the box and then tried to install the standalone installer again, but get the same result.

I am looking for ANY ideas that can help me with this as it's driving me nuts.

If I look at the Certificate on dotNetFx40_Full_x86_x64.exe it shows Valid from 12/7/2009 to 3/72011, so it's expired. I thought that may be the issue, so I set my clock back to 1/1/2011 and retried the installation but it still fails.




Responses
Author: Narayanan             
Posted Date: September 18, 2011     Points: 20   

Hi,
Try this links
http://answers.microsoft.com/en-us/windows/forum/windows_other-windows_update/error-code-0x800b010b-after-trying-to-install-net/797ea3d0-885e-42e5-a6c1-9bcbfe99faa4
http://www.zxro.net/uncategorized/fix-0x800b010b/
Regards,
Lakshmi Narayanan.S

Regards, Lakshmi Naraayanan.S
http://dotnettechrocks.blogspot.in/


Post Reply

You must Sign In To post reply
 
 
Find more Forum Questions on C#, ASP.Net, Vb.Net, SQL Server and more Here
Quick Links For Forum Categories:
ASP.NetWindows Application  .NET Framework  C#  VB.Net  ADO.Net  
Sql Server  SharePoint  OOPs  SilverlightIISJQuery
JavaScript/VBScriptBiztalkWPFPatten/PracticesWCFOthers
www.DotNetSpark.comUnAnsweredAll

Hall of Fame    Twitter   Terms of Service    Privacy Policy    Contact Us    Archives   Tell A Friend